How to check the AIX server Configuration details
- Find the OS, (ML/)TL (-r), and service pack version / date (-s)
oslevel -r ⇐or⇒ oslevel -s
- List all attributes of system
getconf -a
- Find the type of kernel loaded (use -a to get all options)
getconf KERNEL BITMODE
bootinfo and getconf can return much of the same information, getconf returns more and has the grepable -a option.
- Find the level of firmware on a system
invscout ⇐or⇒ lscfg -pv
- List all attributes for the kernel “device”
lsattr -El sys0
- Print a “dump” of system information
prtconf
- Get all page sizes supported on this system
pagesize -a
How to query users and groups in AIX
- List all settings for root user in grepable format
lsuser -f root
- List just the user names
lsuser -a id ALL | sed ’s/ id.*$//’
- Find the fsize value for user wfavorit
lsuser -a fsize wfavorit
- Change the fsize value for user wfavorit
chuser fsize=-1 wfavorit
(/usr)/bin/sh and (/usr)/bin/ksh are the same file. Use bsh for the Bourne shell.
How to query installed software packages in AIX
- List all files in bos.games fileset.
lslpp -f bos.games
- Find out what fileset “fortune” belongs to.
lslpp -w /usr/games/fortune
- List packages that are above the current OS level
oslevel -g
- Find packages below a specified (ML/)TL
oslevel -rl 5300-05
- List all filesets
lslpp -L
- List all filesets in a grepable or awkable format
lslpp -Lc
- Find the package that contains the filemon utility
which -fileset filemon
- Install the database (from CD/DVD) for which fileset
installp -ac -d /dev/cd0 bos.content list
- Create a mksysb backup of the rootvg volume group
mksysb -i /mnt/server1.mksysb.‘date +%m%d%y‘
- Cleanup after a failed install
installp -C