AIX Commands to monitor System Resource Controller (SRC)
Most SRC based services are started from /etc/rc.tcpip
- Start the xntpd service
startsrc -s xntpd
- Stop the NFS related services
stopsrc -g nfs
- Refresh the named service
refresh -s named
- List all registered services on the system
lssrc -a
- Show status of ctrmc subsystem
lssrc -l -s ctrmc
AIX Commands to monitor system performance
CPU performance
mpstat
topas -P
lparstat
ps
iostat -tT 1
tprof†
curt† —— (†Denotes trace based tools.)
Memory performance
vmstat
svmon
ps -o fields
topas
ipcs -m
Network I/O performance
[ent|tok|fddi|atm]stat
netstat
netpmon†
topas -E
Disk I/O performance
iostat
fcstat
lvmstat
filemon†
fileplace
topas -D
Application performance
truss
probevue
tprof†
svmon -P pid
ps -o fields -p pid
topas
The ~ character toggles to nmon-mode in topas
Other performances
Check for disk stat history collection
lsattr -HEl sys0 -a iostat
Enable historical disk statistic collection
chdev -l sys0 -a iostat=true
AIX Commands to monitor Memory and Paging space
- List size, summary, and paging activity by paging space
lsps -a
- List summary of all paging space
lsps -s
- List the total amount of physical RAM in system
lsattr -El sys0 -a realmem
- Create a new paging device on rootvg of 64 PPs
mkps -a -s 64 -n rootvg
- Extend the existing paging space by 8 PPs
chps -s 8 hd6